`
玉箫客
  • 浏览: 12381 次
最近访客 更多访客>>
社区版块
存档分类
最新评论

杭电2680 迪杰特斯拉算法的应用

c 
阅读更多
题目描述:
Problem Description:
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.


Input:
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.



Output:
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.


Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1


Sample Output
1
-1

注意细节(红色字体)···
AC代码·····
*********************************************
#include"stdio.h"
#include"string.h"
#define MAX 10000000
int time[1001],map[1001][1001],mark[1001];
int main()
{
int n,m,p,q,s,t,i,j,k,W,w,sum,min;
while(scanf("%d%d%d",&n,&m,&s)!=EOF)
{
for(i=0;i<=n;i++)
for(j=0;j<=n;j++)
map[i][j]=MAX;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&p,&q,&t);
if(map[p][q]>t)
map[p][q]=t;
}
scanf("%d",&W);
sum=MAX;
for(i=0;i<W;i++)
{
scanf("%d",&w);
map[0][w]=0;
}
memset(mark,0,sizeof(mark));
for(j=0;j<=n;j++)
time[j]=map[0][j];
time[0]=0;
mark[0]=1;
for(j=0;j<=n;j++)
{
min=MAX;
for(k=0;k<=n;k++)
{
if(mark[k]==0&&time[k]<min)
{
min=time[k];
t=k;
}
}
if(min==MAX)
break;
mark[t]=1;
for(k=0;k<=n;k++)
{
if(!mark[k]&&time[k]>(time[t]+map[t][k]))
time[k]=time[t]+map[t][k];
}
}
if(sum>time[s])
sum=time[s];

if(sum==MAX)
printf("-1\n");
else
printf("%d\n",sum);
}
return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics